USB hub doesn't work with USB 3.0 cables

Discussion about the UCH, our industrial grade, smart USB3 Hub
Post Reply
Posts: 1
Joined: Thu Nov 18, 2021 4:53 pm

USB hub doesn't work with USB 3.0 cables

Post by goodeye »

I'm having connectivity issues with my new Pegasus USB hub.

> My equipment: Ioptron CEM 40 (USB 2.0), ASI183 MC Pro image camera (USB 3.0), ASI 120 MM-S guide cam (USB 3.0), ZWO EAF 5 volt version (USB 2.0), 2 each SVBONY USB powered heaters for the cameras (USB something), and a William Optics Z61 scope which is no factor in my problem.

> After installing the Pegasus software, current as listed on their website, I had erractic behavior from primarily the ZWO products (2 of them are USB 3.0). All of the ZWO and Ioptron software is up to date. All of my components worked just fine prior to installing the hub. I had a cable nightmare but everything worked. I use NINA and PHD2. Sometimes the cameras (either one or both) would connect with NINA and sometimes they wouldn't. Same with PHD2. Sometimes the EAF would not talk with NINA or PHD2. I thought maybe the stock ZWO cables were too long so I replaced them with some of the Pegasus USB 3.0 short cables and that did not fix the issue. I even upgraded NINA to the latest beta version, PHD2 is also current.

> So I started swapping cables all around in various orders, different lenghts, different USB formats (2.0 vs 3.0) and finally found what works and what doesn't work.

> If my USB 3.0 cameras are plugged into the hub with ANY USB 3.0 cable the issue is duplicated and most of the time would not even be recognized by PHD2 or NINA or even the Pegasus hub control app. When either camera is connected to the hub with ANY USB 2.0 cable that particular camera is reconized so when I plug in both cameras with a USB 2.0 cable everything works fine.

> To further evaluate the hub I did some more testing. I connected my cameras into the USB ports of the mount itself with USB 3.0 cables and everything works. I connected my cameras directly into my laptop with USB 3.0 cables and everything works. That eliminates any hardware issues with my gear, except of course for the hub itself. Bottom line I cannot get ANY USB 3.0 piece of hardware to connect to or though the hub with a USB 3.0 cable. With a USB 2.0 cable it all works great. I don't know if there is something else to configure in the hub or if there just something in the hub that will not talk to a USB 3.0 cable. I have tried all the ports. I have tried 2 power sources. One is a regulated LiFe 13.8vdc 10a battery pack (similar to Jackery that lots of people use) and the other is a regulated AC unit which outputs 13.8vdc and capable of 20 amps so power is not the problem. Right now with everything connected via USB 2.0 cables it all works fine. Any thoughts?
Posts: 9
Joined: Fri Jan 14, 2022 6:32 pm

Re: USB hub doesn't work with USB 3.0 cables

Post by rodolgo »

I have exactly the same issues with the UPBv2 and came to the same conclusion: to me the USB3 hub part is not functional; I suspect this is the same hardware for both.
Would be good to receive a reply from Pegasus about it.
See post I logged in the UPB forum section.
Hopefully this can be resolved by a firmware update, I keep fingers crossed.
Posts: 3
Joined: Thu Jun 30, 2022 8:36 pm

Re: USB hub doesn't work with USB 3.0 cables

Post by Mikeatsr »

Has there been any resolution to this issue?
User avatar
Site Admin
Posts: 413
Joined: Wed Dec 02, 2020 3:06 pm

Re: USB hub doesn't work with USB 3.0 cables

Post by Evans »

The USB Hub IC is an industrial Hub with lots of protections around. We have seen cases where the USB Hub circuitry got damaged from severe ESD spikes (thunderstorm, very high energy) or cases where voltage above 5V passed into USB lines. (e.g someone connected another USB hub which was operating with 5V into the UPBv2 12V output).
To be honest, we are very proud of this implementation as the UCH flew to ISS.
If there is a problem you can contact us directly to troubleshoot further.

Firmware upgrade is completely non related to this issue. The Hub does not require a firmware upgrade and it is fully isolated from the remaining circuit. (power distribution)
Post Reply