Rotator sometimes does not move with Nina command

Questions and feedback about the rotator itself, adapters, de-rotation etc
Post Reply
Posts: 30
Joined: Fri Mar 26, 2021 9:27 pm

Rotator sometimes does not move with Nina command

Post by cwoodhou »

I’m not entirely sure whether this is a Falcon or a Nina issue, but I occasionally get an instance where the falcon rotator does not move after a Nina move command. Nina does not have a timeout, and the sequence hangs. If I go into the Unity driver and change the angle to the desired Value, it frees up Nina and it continues.

Has anyone else seen this?
User avatar
Site Admin
Posts: 504
Joined: Wed Dec 02, 2020 3:06 pm

Re: Rotator sometimes does not move with Nina command

Post by Evans »

Can you please provide the exact steps on how to replicate this issue?
Posts: 4
Joined: Sun Feb 18, 2024 4:09 pm

Re: Rotator sometimes does not move with Nina command

Post by FAstro »

Yes, I have seen this problem. Below is what happened:

I have been using the Falcon for several years and never had a problem with my previous mount, but I have seen this happen a few times since I purchased the NYX-101 mount about a month ago. The first couple of times it must have happened slewing to my second target late at night. I did not follow up, attributing it to something I had not set right or a cable snag as I was testing the mount.

I have finally worked out all of the kinks I had with my new equipment working with the new mount. A couple of days ago I was out to image. I use the Advanced Sequencer in NINA. When it got to the Slew, Center, and Rotate command NINA slews to the target and initiates the command to Rotate 50 degrees to my target. The usually works fine, it plate solves, rotates, solves, etc until target angle is achieved. This time, I watch as NINA tries 4-5 times with different mechanical angles; it can’t find the proper mechanical angle but keeps trying (this behavior has happened when I don't have Reverse=ON set, but it was ON this time). I realize that there is a problem and stop the NINA sequence. I went into UNITY and sent the Falcon back to its 0 position.

This time I went outside to see where the Falcon was positioned and saw that rotator was not at 0 position, it was in some random position. Using UNITY I moved rotator to its approximate zero position, synced it to 0 and tried NINA again. This time I watched more carefully. NINA computed a mechanical slew of 137.43 degrees (which was correct) and sent the command to move the rotator 137.43 degrees. NINA puts a message at the bottom left of the screen telling user what it is doing and it says Rotating to 137.43. The command never finished, just sat on the screen like it was still rotating. This time I checked UNITY to see what the rotator was doing and the Falcon had stopped at 70.9 degrees. I went outside and it appeared to be at 70.9degrees. I paused the NINA sequence. I went back into UNITY and moved the rotator to 137.43. Unity rotated to 137.43 and stopped. This was correct angle and I started imaging.

There are no errors shown or anything unusual in the NINA log file.

No cable snags, actually not even possible with my setup withe rotator in front of my field flattener and current camera cable management on NYX-101 mount.

Don’t believe is a cable problem as I can use the UNITY interface just fine to communicate with the Falcon. I had no issues manually telling it to Go To angles or Syncing it.

It appears that either NINA is sending the wrong values (unlikely), they are being received wrong by Falcon, or Falcon just stops during rotation before it finished

Note that I am running most up-to-date Falcon firmware 1.6 Rev. A and UNITY is up-to-date as well.

Can you please investigate?
Post Reply