Unity Program not Loading

Feature requests / 3rd party software development
Post Reply
sreilly24590
Posts: 3
Joined: Sun Jul 10, 2022 2:57 pm
Location: Virginia

Unity Program not Loading

Post by sreilly24590 »

When I try to Open the newest Unity program on my observatory computer it flat out won't run. I made sure power was on the Pegasus although that shouldn't keep the program from running it simply wouldn't find the UPBv2 correct? I ended up having to uninstall and reinstall the program to get it to execute. Trying by Run as Administrator didn't work, rebooting didn't work but uninstall/reinstall did. I also made sure it was the newest build, which as far as I can tell, isn't listed in the download title but was downloaded and installed again today. The previous one was installed several weeks ago when I started to use the unit. The notice of an update was followed by my downloading and installing it over the current older version.

I have no idea why this program wouldn't run before the uninstall/reinstall, even after a clean reboot.

-Steve
cwoodhou
Posts: 16
Joined: Fri Mar 26, 2021 9:27 pm

Re: Unity Program not Loading

Post by cwoodhou »

Mine has seemingly come up blank too - but the server is running and I can connect through ASCOM still.

When I look at Task Manager, only the server is running.
Mnorman
Posts: 6
Joined: Sun Aug 15, 2021 1:40 pm

Re: Unity Program not Loading

Post by Mnorman »

Same problem here. Was working fine, but after re-booting after latest windows update, Unity no longer loads.
Mnorman
Posts: 6
Joined: Sun Aug 15, 2021 1:40 pm

Re: Unity Program not Loading

Post by Mnorman »

Update:

Downloaded latest version (1.6.1062.39) and it loads now.

I presume this was a fix.
User avatar
Evans
Site Admin
Posts: 412
Joined: Wed Dec 02, 2020 3:06 pm
Contact:

Re: Unity Program not Loading

Post by Evans »

Yes, had to do with a recent windows update (it happens under certain circumstances). Please upgrade to the latest Unity which fixes the issue.
pleiades
Posts: 17
Joined: Wed Nov 23, 2022 8:48 pm
Location: Quebec, Canada

Re: Unity Program not Loading

Post by pleiades »

Evans wrote: Mon Nov 14, 2022 1:04 pm Yes, had to do with a recent windows update (it happens under certain circumstances). Please upgrade to the latest Unity which fixes the issue.
Hi Evans,

It could be great to add the update version number into Unity Platform filename. i.e. PegasusAstroUnityPlatform_v1.6.1202.43 Thanks!

Regards,
Yves
jimki
Posts: 1
Joined: Thu Nov 24, 2022 7:19 am

Re: Unity Program not Loading

Post by jimki »

Mnorman wrote: Wed Nov 09, 2022 3:58 am Update:

Downloaded latest version (1.6.1062.39) and it loads now.

I presume this was a fix.
I have the same problem and it disappeared after the update, just want to confirm it.
Recently I knew that those who have May 23 zodiac are communicators and intermediaries. By the way, I was born on this day and I am a proud Gemini.
User avatar
astroisk
Posts: 6
Joined: Mon Dec 05, 2022 6:43 pm

Re: Unity Program not Loading

Post by astroisk »

Same problem for me with latest Unity Platform 1.6.1230.46 and latest Windows 10 Pro 22H2 19045.2251. The Unity splash appears as normal then dissappears but no UI is shown, and task manager shows only Peg.Server. Reverted to previously installed 1.4.36.5 and everything works again.
User avatar
Evans
Site Admin
Posts: 412
Joined: Wed Dec 02, 2020 3:06 pm
Contact:

Re: Unity Program not Loading

Post by Evans »

No issues have been reported with latest Release Version : 1.6.1230.46
I tested with Windows 10 and 11 with latest updates
User avatar
astroisk
Posts: 6
Joined: Mon Dec 05, 2022 6:43 pm

Re: Unity Program not Loading

Post by astroisk »

Windows event viewer .NET crash report:

Application: Peg.UI.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Exception
at Peg.UI.Core.ConfigurationProvider.AddUpdateAppSettings(System.String, System.String)
at Peg.UI.Core.ConfigurationProvider.set_Theme(Peg.UI.Theming.Theme)
at Peg.UI.Theming.LookAndFeelService.SetSkin(Peg.UI.Theming.Theme)
at Peg.UI.Theming.LookAndFeelService.InitializeSkin()
at Peg.UI.View.Main..ctor(Peg.CoreServices.Abstractions.IoC.IDependencyContainer, Peg.CoreServices.Abstractions.MessageBus.IMessageBusService, Peg.UI.Theming.LookAndFeelService, Peg.UI.Events.IDomainEventService, Peg.UI.Core.WaitScreenService, Peg.UI.Core.IAlertNotificationService, Peg.UI.Infrastructure.UpdateService, Peg.UI.Core.IConfigurationProvider, Peg.CoreServices.Abstractions.Logging.ILoggerFactory)
at DynamicClass.lambda_method(System.Runtime.CompilerServices.Closure, System.Object[])
at Autofac.Core.Activators.Reflection.BoundConstructor.Instantiate()

Exception Info: Autofac.Core.DependencyResolutionException
at Autofac.Core.Activators.Reflection.BoundConstructor.Instantiate()
at Autofac.Core.Activators.Reflection.ReflectionActivator.ActivateInstance(Autofac.IComponentContext, System.Collections.Generic.IEnumerable`1<Autofac.Core.Parameter>)
at Autofac.Core.Activators.Reflection.ReflectionActivator.<ConfigurePipeline>b__11_0(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Middleware.DelegateMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.Middleware.DisposalTrackingMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Peg.UI.Localization.LocalizationMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.Middleware.ActivatorErrorHandlingMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)

Exception Info: Autofac.Core.DependencyResolutionException
at Autofac.Core.Resolving.Middleware.ActivatorErrorHandlingMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Pipeline.ResolvePipeline.Invoke(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.Middleware.RegistrationPipelineInvokeMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.Middleware.SharingMiddleware+<>c__DisplayClass5_0.<Execute>b__0()
at Autofac.Core.Lifetime.LifetimeScope.CreateSharedInstance(System.Guid, System.Func`1<System.Object>)
at Autofac.Core.Lifetime.LifetimeScope.CreateSharedInstance(System.Guid, System.Nullable`1<System.Guid>, System.Func`1<System.Object>)
at Autofac.Core.Resolving.Middleware.SharingMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.Middleware.ScopeSelectionMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.Middleware.CircularDependencyDetectorMiddleware.Execute(Autofac.Core.Resolving.Pipeline.ResolveRequestContext, System.Action`1<Autofac.Core.Resolving.Pipeline.ResolveRequestContext>)
at Autofac.Core.Resolving.Pipeline.ResolvePipelineBuilder+<>c__DisplayClass14_0.<BuildPipeline>b__1(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Pipeline.ResolvePipeline.Invoke(Autofac.Core.Resolving.Pipeline.ResolveRequestContext)
at Autofac.Core.Resolving.ResolveOperation.GetOrCreateInstance(Autofac.Core.ISharingLifetimeScope, Autofac.ResolveRequest)
at Autofac.Core.Resolving.ResolveOperation.ExecuteOperation(Autofac.ResolveRequest)
at Autofac.Core.Lifetime.LifetimeScope.ResolveComponent(Autofac.ResolveRequest)
at Autofac.Core.Container.ResolveComponent(Autofac.ResolveRequest)
at Autofac.ResolutionExtensions.TryResolveService(Autofac.IComponentContext, Autofac.Core.Service, System.Collections.Generic.IEnumerable`1<Autofac.Core.Parameter>, System.Object ByRef)
at Autofac.ResolutionExtensions.ResolveService(Autofac.IComponentContext, Autofac.Core.Service, System.Collections.Generic.IEnumerable`1<Autofac.Core.Parameter>)
at Autofac.ResolutionExtensions.Resolve[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](Autofac.IComponentContext, System.Collections.Generic.IEnumerable`1<Autofac.Core.Parameter>)
at Autofac.ResolutionExtensions.Resolve[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](Autofac.IComponentContext)
at Peg.UI.Program.Main()
User avatar
Evans
Site Admin
Posts: 412
Joined: Wed Dec 02, 2020 3:06 pm
Contact:

Re: Unity Program not Loading

Post by Evans »

Check and delete c:/Windows/temp/ files you should have a conflict file named "autofac" there.
User avatar
astroisk
Posts: 6
Joined: Mon Dec 05, 2022 6:43 pm

Re: Unity Program not Loading

Post by astroisk »

WER.zip
(3.89 KiB) Downloaded 21 times
no "autofac" present in temp but cleared anyway and rebooted, same issue. Windows error report shows:

Fault bucket 1947146356429419728, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: Peg.UI.exe
P2: 1.6.1230.46
P3: 638516f3
P4: Peg.UI
P5: 1.6.1230.46
P6: 638516f3
P7: ee6
P8: 63
P9: GQ4LHWPDDL0MLXLXMR0BYB3HLMJR32NC
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB993.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERBCD0.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERBD10.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERBD21.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERBD70.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Peg.UI.exe_c486f7b7643381f3c5e67b2f769b1b53cfda6691_91416e98_c946baa9-932b-4229-bc23-96ceef16a1a7

Analysis symbol:
Rechecking for solution: 0
Report Id: aa23cab5-652d-4182-8030-11f4be9a9e34
Report Status: 268435456
Hashed bucket: ad11b22f29e6a0435b05a74b74abf4d0
Cab Guid: 0
User avatar
astroisk
Posts: 6
Joined: Mon Dec 05, 2022 6:43 pm

Re: Unity Program not Loading

Post by astroisk »

UPDATE: The problem was due to Unity being installed on D: drive where I install all my non-system apps. Removing it and reinstalling to C: drive worked. Removing it again and reinstalling to D: drive failed, so the issue appears to be repeatable. Perhaps there is a .NET configuration setting that is harcoded for the C: drive?
User avatar
Evans
Site Admin
Posts: 412
Joined: Wed Dec 02, 2020 3:06 pm
Contact:

Re: Unity Program not Loading

Post by Evans »

Thank you for reporting this. We'll investigate why this happens.
Post Reply