Power Box Micro loses connection when sensor plugged in

Post Reply
hodietel
Posts: 1
Joined: Thu Aug 25, 2022 2:32 pm

Power Box Micro loses connection when sensor plugged in

Post by hodietel »

Hi,

I recently got a Power Box Micro. After installing and running the "Pocket Powerbox", I was able to update the firmware to V 2.7. After doing so the program did not recognize the box any more but it now worked with the Unity Platform.
Now when I do not connect the temp/humidity sensor all worked fine but as soon as I connect the sensor the connection to the box is cancelled and the computer says "usb device not recognized".
Does anyone have any idea?

Best regards

P.S.
When I start the Unity Platform and the Pocket Power Box Micro app with sensor plugged in I get an exception:

System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei Peg.UI.View.Controls.PPBMicro.DewHubPPBControl.OnInitialize()
bei Peg.UI.View.Controls.BaseControl.OnFirstLoad()
bei DevExpress.XtraEditors.XtraUserControl.OnLoad(EventArgs e)
bei System.Windows.Forms.UserControl.OnCreateControl()
bei System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
bei System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
bei System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
bei System.Windows.Forms.Control.CreateControl()
bei System.Windows.Forms.Control.WmShowWindow(Message& m)
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
bei System.Windows.Forms.ContainerControl.WndProc(Message& m)
bei System.Windows.Forms.Form.WmShowWindow(Message& m)
bei System.Windows.Forms.Form.WndProc(Message& m)
bei DevExpress.XtraEditors.XtraForm.WndProc(Message& msg)
bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

27.8. Here some results from further investigations:
- without connection to PC the dew control with sensor works
- the above situation is with Power Box connected to PC via PegasusAstra USB Hub
- when connecting the Power Box directiy to the PC, I can click "continue" when the exception (see above) arises and the app works with the sensor, also the update rate seem slower as without sensor
- same behaviour on another PC (both with Windows 10 and Pegasus Astro Unity Platform 1.5.84.12)
So I think the communication between PC and Box is somehow disturbed when the sensor is connected. When connected via USB Hub the communication does not work anymore
Post Reply