New PC will not connect

Ultimate Powerbox v1 and v2
Post Reply
CCDAstro
Posts: 2
Joined: Sat Jun 11, 2022 4:37 pm

New PC will not connect

Post by CCDAstro »

I have a new PC (Windows 10 Home). I also have two UPB V2 and one PPB advance. The PPB will connect just fine but neither of the UPBs will connect. The port (in this case USB 4) does show up in device manager when I plug the UPBs in and goes away when I unplug it. No ports show up in the older software and auto select does not work.
I have tried both the older SW and Unity and can get no connection to either of my UPBs. I have tried different USB ports, different cables, different power supplies and both of my UPBs - none connect with this PC and all connect with the older PC. I tried this with both the PPB and UPB on and with the PPB off and totally unplugged - it made zero difference.

What gives? I really need this new PC (it works with every other piece of astro hardware and software).
Attachments
connection.png
connection.png (32.3 KiB) Viewed 140 times
connection2.png
connection2.png (56.48 KiB) Viewed 140 times
CCDAstro
Posts: 2
Joined: Sat Jun 11, 2022 4:37 pm

Re: New PC will not connect

Post by CCDAstro »

OK, solved the problem. Apparently both UPB V1 had old firmware that would not work with anything except an older version of the software (older than is available on the website). I found an old version on one of my PCs and installed it and now it works.

That begs the question of how to upgrade the firmware these days on a V1 box? The "upgrade" link shown on the old but functional (1.4.7) software is now dead.
Post Reply