UPBv2 USB ports defaulting to off

Ultimate Powerbox v1 and v2
Post Reply
RandomTourist
Posts: 3
Joined: Mon Aug 01, 2022 1:12 pm

UPBv2 USB ports defaulting to off

Post by RandomTourist »

Hello

I am attempting to use the UPBv2 to power a Pi4b for stellarmate control in the field.
When power is cut to the UPBv2 it seems to forget that the USB ports were toggled active. This prevents the UPBv2 from powering the Pi.
I then need to power the Pi externally to get into Ekos/Indi to toggle the USB ports active. Then I can switch to powering the Pi via USB.

Is there no way to make the toggle persist over power down?
Capture.PNG
Capture.PNG (62 KiB) Viewed 53 times
Really defeats the intent of running one cord if I have to bring a additional power supply just for the initial boot.
User avatar
Evans
Site Admin
Posts: 324
Joined: Wed Dec 02, 2020 3:06 pm
Contact:

Re: UPBv2 USB ports defaulting to off

Post by Evans »

There must be a bug or not implemented feature in INDI driver.
As a quick workaround please try to connect the UPBv2 to a windows PC and enable all USB ports during startup. There is an option in software to do that.
RandomTourist
Posts: 3
Joined: Mon Aug 01, 2022 1:12 pm

Re: UPBv2 USB ports defaulting to off

Post by RandomTourist »

OK. I installed the UNITY software and toggled the USB ports on. Initial test looks promising. ON state persisted over a short power down.

Are the USB normally set to off by default?
Capture.PNG
Capture.PNG (15.32 KiB) Viewed 42 times
RandomTourist
Posts: 3
Joined: Mon Aug 01, 2022 1:12 pm

Re: UPBv2 USB ports defaulting to off

Post by RandomTourist »

This solution worked if anyone has the same issue.
Post Reply